Beiträge von windsurferin

    Danke für die Info. Ich bekomme immer den Fehler Error Code: 4011 Befehl {http://www.buergerkarte.at/namespaces/securitylayer/1.2#}CreateCMSSignatureRequest ist nicht implementiert.
    Mein Formular beginnt wie folgt:
    <form action="http://127.0.0.1:3495/http-security-layer-request" enctype="multipart/form-data" method="post" name="signForm">
    <table border=0>
    <tr><td>XMLRequest:</td><td><textarea name="XMLRequest" cols="100" rows="20"><?xml version="1.0" encoding="UTF-8"?>
    <sl:CreateCMSSignatureRequest Structure="enveloping" xmlns:sl="http://www.buergerkarte.at/namespaces/securitylayer/1.2#">
    <sl:KeyboxIdentifier>SecureSignatureKeypair</sl:KeyboxIdentifier>
    Mir ist aufgefallen, dass die URL "http://www.buergerkarte.at/namespaces/securitylayer/1.2#" nicht aufrufbar ist, weil ein 404 Fehler kommt. Was muss man statt dieser URL eintragen? Ich möchte lediglich ein simples Formular haben auf welchem ich eine Datei angebe welche ich mittels meiner lokalen BKU signiere.


    Danke & lG!

    Danke für die schnellen Antworten und den Link zur Spezifikation. Beim Demologin gibt es keinen Fehler. Wir haben eine eigene (alte) Applikation welche mit trustview einwandfrei funktioniert hat. Nun habe ich es mit den beiden oben angeführten Bürgerkartenumgebungen probiert und mit keiner von beiden läuft die Anwendung mehr, darum habe ich probiert diese URL direkt aufzurufen um zu sehen was sich dahinter verbirgt. Ist es prinzipiell richtig, dass alle Bürgerkartenumgebungen die gleiche Schnittstelle und Funktionalitäten haben, dh sollte unsere Applikation auch weiterhin funktionieren?


    Danke & lG!

    Hallo miteinander,


    ich hoffe ich darf mit meiner Frage an diese anknüpfen weil sie zum Thema passt: in der Spezifikation sind die Fehlercodes dokumentiert, allerdings weiß ich nicht, wie ich den Fehler beheben kann bzw. woran dieser genau liegt. Ich habe den Fehler "2004 HTTP/HTTPS-Bindung: Parameter XMLRequest fehlt." wenn ich http://127.0.0.1:3495/http-security-layer-request aufrufe. Ich habe die a-Trust-Bürgerkartenumgebung und diese ist auch ordnungsgemäß gestartet und einsatzbereit.
    Zuvor hatte ich dieses Problem bereits mit Mocca. Mocca habe ich deshalb allerdings deinstalliert und hoffte, dass es mit einer anderen Bürgerkartenumgebung klappen würde. Was für ein Parameter ist das bzw. wo und wie kann ich diesen einstellen?


    Vielen Dank & liebe Grüße!