Beiträge von valup

    Oracle hat schon vor geraumer Zeit angekündigt, mit Java 11 unter anderem Java Web Start. Leider ist unter Linux Mocca über JWS derzeit die einzige Möglichkeit, die Bürgerkarte zu verwenden. Gibt es schon Überlegungen, wie das in Zukunft ermöglicht werden könnte?


    Die Handy-Signatur ist mMn leider kein gleichwertiger Ersatz, die Unsicherheit von SMS als zweitem Faktor ist hoffentlich hinlänglich bekannt. Sollte man zukünftig auf eine „App“ mit lokalem Client-Zertifikat setzen, wäre dass zwar sicherer, aber erst wieder auf bestimmte Betriebssysteme (wahrscheinlich ausschließlich Android und iOS) und außerdem Smartphone-Besitzer beschränkt. Ganz abgesehen davon, dass Handys eine ganz andere Verwendung finden als eine dedizierte Smartcard.

    Beim Versuch PDF-Over unter Linux zu installieren bekomme ich reproduzierbar diese hässliche Fehlermeldung:

    Code
    1. java.io.IOException: Corrupted pack file: magic/ver = CAFED00D/171.0 should be CAFED00D/150.7 OR CAFED00D/160.1
    2. at com.sun.java.util.jar.pack.NativeUnpack.start(Native Method)
    3. at com.sun.java.util.jar.pack.NativeUnpack.run(Unknown Source)
    4. at com.sun.java.util.jar.pack.NativeUnpack.run(Unknown Source)
    5. at com.sun.java.util.jar.pack.UnpackerImpl.unpack(Unknown Source)
    6. at com.izforge.izpack.installer.Unpacker.run(Unknown Source)
    7. at java.lang.Thread.run(Unknown Source)

    Quelle des JARs: https://webstart.buergerkarte.at/PDF-Over/


    Ich werde jetzt erstmal die alte Version aus dem Backup wiederherstellen … ||

    Seit dieser Woche, wahrscheinlich in unmittelbarem Zusammenhang mit dem Zertifikatswechsel verweigert mir Mocca den Start mit der folgenden Fehlermeldung:

    Next stop: Reboot des Systems, wer weiß, vielleicht wird was gecached, dass nicht gecached werden sollte.

    derzeit kommt es zu technischen Problemen mit dem neuesten Java Update (1.8.141). Die Spezialisten des EGIZ arbeiten bereits an der Problemanalyse und –behebung.


    Gut zu wissen.



    Die Java 8u141 Release Notes erwähnen diesbezügliche Änderungen, die aber abwärtskompatibel sein hätten sollen. Ich bin schon gespannt, wann wir da einen Fix bekommen. Derweil hat aber das Downgrade auf 8u131 ausgereicht um Mocca wieder zum Zusammenspielen zu bringen.