PDF-Over 4.2.1 erst ab macOS High Sierra (wegen APFS Image)?

  • PDF-Over läuft grundsätzlich unter jeder macOS Version, die Java 8 unterstützt, also ab macOS 10.8.3 [1] (obwohl auf buergerkarte.at immer noch Java 7 steht ...)


    Nun wird PDF-Over in der aktuellen Version 4.2.1 für den Mac auf einem .dmg Image ausgeliefert, das mit dem neuen Filesystem APFS formatiert ist, das erst ab macOS 10.13 "High Sierra" lesbar ist [2]. Durch diese (bewusste oder unbewusste?) Neuerung wird Benutzern auf älteren Versionen von macOS die Installation bzw. das Update unnötig erschwert.


    Bitte das rückgängig zu machen!


    Mit besten Grüßen,
    Florian Sedivy

  • Danke für den Hinweis.


    Wir erstellen das .dmg Image mit der aktuellsten Version von macOS. Das von Ihnen geschilderte Problem basiert also nicht auf einer von uns bewusst getroffenen Entscheidung, sondern ist bedingt durch die Sicherheitspolitik von Apple.


    Da für den Release allerdings ein eigener Prozess durchlaufen werden muss, kann die aktuellste Version nicht einfach ausgetauscht werden. Wir werden dies aber beim nächsten Release berücksichtigen.


    Nichtsdestotrotz sollte das Betriebssystem am aktuellsten Stand gehalten werden, um mögliche Missbräuche bei der Verwendung von digitalen Signaturen vorzubeugen.