Upgrade auf PDF-Over 4.1.2 - Signatur mit Chipkarte funktioniert nicht mehr!

  • Ich habe heute zwei Upgrades der PDF-Over Software, zuerst auf die Version 4.1.1 und unmittelbar danach auf die Version 4.1.2, durchgeführt. Seit dem Upgrade kann ich nicht mehr mit Chipkarte unterschreiben. Ich habe es mit 2 verschiedenen Bürgerkarten und einer a.sign premium-Karte versucht. Es erscheint ein Fenster mit der Fehlermeldung "Signatur-Fehler". Die Unterschrift über Handy-Signatur funktioniert ohne Probleme.


    Vor dem Upgrade auf 4.1.2 haben beide Varianten (Chipkarte und Handy) funktioniert.


    Ich verwende WIndows 8.1 64bit und Java 8 Update 40. Ich habe sowohl die 32bit als auch die 64bit Version von Java installiert.


    Das Log-File kann ich bei Bedarf gerne als PN versenden. Einige Zeilen mit dem "Crash" folgen:


    ---END XML---
    21:31:03 MESSAGE (14216): ReadSecurityLayerXml DOM
    21:31:03 MESSAGE (14216): ReadSecurityLayerXml returns true
    21:31:03 MESSAGE (14216): Create_Signature_CMS
    21:31:03 MESSAGE (14216): SchemaCache::CheckSecurityLayerVersion
    21:31:03 ERROR (14216): SAX-Error: Unknown element 'ExcludedByteRange'; Line: 11; Column Number: 28
    21:31:03 ERROR (14216): SAX-Error: Element 'ExcludedByteRange' is not valid for content model: '(MetaInfo,Content)'; Line: 15; Column Number: 18
    21:31:03 MESSAGE (14216): SchemaCache::checkWithParser error occured, returns false
    21:31:03 MESSAGE (14216): ErrorResponse
    21:31:03 MESSAGE (14216): DoErrorResponse
    21:31:03 DEBUG (14216): RESPONSE:
    ---BEGIN XML---


    Danke für Euren Input!

  • Sieht so aus, als ob Sie die ATrust BKU verwenden. Die Fehlermeldung ExlcudedByteRange deutet darauf hin, dass es sich dabei um eine alte Version handelt. Bitte diese updaten oder Mocca Lokal verwenden (is auf buergerkarte.at zu finden.).


    mfg, cm

  • Danke für die rasche Rückmeldung!


    Ich verwende die a-trust Bürgerkartensoftware in der Version 1.4.3.2 mit Implementierung der Bürgerkartenspezifikation 1.2. Lt. "Programm-Update" ist keine neuere Version verfügbar.


    Beim Versuch der Installation von Mocca bekomme ich die Fehlermeldung, dass die für Mocca reservierte Adresse bereits von einer anderen Applikation (a-trust ?) belegt ist, die ich allerdings nicht unbedingt deinstallieren will, weil meine anderen Applikationen in Verbindung mit meinem ReinerSCT cyberJack mit der a-trust Software eigentlich problemlos laufen.


    Kann die Signatur über Chipkarte in PDF-Over mit der nächsten Version wieder funktionieren, oder muss a-trust zwingend ein Update der seiner BKU veröffentlichen?


    BG, EO

  • Nachtrag zum letzten Beitrag...


    Ich habe meine a-trust Bürgerkartensoftware über den a.sign Client von a-trust deaktiviert. Danach startet Mocca erfolgreich und auch die Signatur über PDF-Over funktioniert.


    Es wäre wünschenswert, dass a-trust seine Bürgerkartensoftware auf den neuesten Stand bringt!


    BG, EO