PDF-Over 4.1.2 --> Signatur-Fehler (Handy-Signatur)

  • Nach vielen Probleme,... habe ich es endlich geschafft, dass ich die App wenigstens starten konnte.
    Ich kann ein Dokument auswählen, die Signatur platzieren und dann kommt die Auswahl zwischen Bürgerkarte und Handy-Signatur.
    Da ich nur die Handy-Signatur habe wähle ich diese aus, und...


    .... SIgnatur-Fehler!!!


    Und weiter gehts nicht, immer wieder das Gleiche!!
    Ich habe bereits PDF-Over mehrfach gelöscht, Java mehrfach gelöscht, auch alle Ordner (inkl. .pdf-over und div weitere versteckte Ordner) gelöscht und neu installiert - immer die neueste Version.
    Java verwende ich den JDK, weil die JRE nicht funktioniert (da will er immer beim App-Start, dass ich Java installiere, obwohl schon erledigt!)


    Hat jemand Ideen, wie ich das Werkl zum Rennen bringe??


    Vielen Dank
    Lg
    Wolfgang

  • Hallo,


    gibt's für die Anfrage von wvlach schon eine Lösung? Ich bin in der gleichen Situation.


    Nach langem Suchen in diversen Foren bin ich schon einmal soweit gekommen, dass ich durch das zusätzliche Installieren des JDK 7 die PDF-Over 4.1.2 App starten konnte. Das Dokument reinziehen und die Signatur zu platzieren funktioniert noch. Bei Klick auf "Signieren" kommt aber immer die Fehlermeldung "Signatur-Fehler".


    Mein Betriebssystem: Mac Pro (Ende 2013) mit OSX Yosemite 10.2.2
    Java jdk-7u75
    Ein pdf-over.log File gibt's auf meinem Rechner nicht.


    Vielen Dank,
    LG Wolfram

  • Zur Info:
    Mit den Versionen ab Java Update 71 hat sich anscheinend in Java ein Bug eingeschlichen der das korrekte Laden der Signaturkomponente NUR UNTER MacOS verhindert.
    Wir empfehlen gleich auf Java 8 upzudaten, da mit April diesen Jahres auch die Updateversorgung von Java 7 seitens Oracle eingestellt wird.


    mfg, cm

  • Hallo!


    Erstmal sorry für's späte melden.


    Ich habe nun die Version PDF-over 4.1.2 downgeloadet und es ist leider noch schlechter geworden. Mittlerweile kann ich pdf-Over nichtmal mehr starten, da ich die Meldung erhalte "Die Version ist beschädigt...."
    Trotz mehrfachem download, etc,.. kein Erfolg


    Java 8 Update 40 (built 1.8.0_40-b25)
    Mac OS X Yosemite 10.10.2


    log-file gibt es nicht


    Liebe Grüße
    WV



    P.S. Habe es auch mit der Version 4.1.1 versucht, aber genau das gleiche Problem - "Version beschädigt!"

  • Das ist nicht bei der Installation passiert, sondern erst beim Öffnen.
    Mit dem Ändern der Einstellungen (wie im link oben beschrieben) hat es dann funktioniert.


    Jetzt geht es wieder einen Schritt weiter, ich kann ein Dokument öffnen, den Signaturblock positionieren, aber wenn ich dann auf signieren gehe und Handy-Signatur anklicke, dann kommt die Meldung "Signatur-Fehler" (siehe screenshot)


    Und somit ist's wieder vorbei...

  • Laut Log-File laeuft noch immer java7. Unter MacOs gibt es da immer wieder Probleme mit den Pfaden, bzw. symlinks. Am einfachsten wuerde das ganze funktionieren wenn Sie die Java8 SDK installieren anstatt nur die JRE, siehe http://www.oracle.com/technetw…k8-downloads-2133151.html


    PDF-AS: 4.0.6
    INFO | 2015-04-02 15:49:22,545 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + PDF-AS SCM Revision: c39999295f3345ba5ba6a2f29307eb58e4bc30bc
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + OS Name: Mac OS X
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + OS Version: 10.10.2
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + OS Arch: x86_64
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + JAVA Version: 1.7.0_75-b13
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + JAVA Spec ----------------------------------------------------------
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + JAVA Spec Name: Java Virtual Machine Specification
    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + JAVA Spec Version: 1.7

    INFO | 2015-04-02 15:49:22,555 | main | at.gv.egiz.pdfas.lib.api.PdfAsFactory - + JAVA Spec Vendor: Oracle Corporation

  • Sg Herr Maierhofer!


    Ich habe Java unter dem von Ihnen angegebenen link heruntergeladen und einfach drüber-installiert.
    Danach habe ich eine "Probe-Signatur" gemacht - es hat geklappt. (Ich habe das pdf-Over nicht erneut installiert, sondern die bestehende Installation verwendet!)


    Danke für Ihre geduldige Unterstützung.
    Mit freundlichen Grüßen
    Wolfgang Vlach