PDF-Over mit Java 7 unter Mac OS X 10.9.1

  • Installiert habe ich es mittels des Webstart-Installers und bei der installation wurde Java 7 ausgeführt. Beim Starten der Applikation kommt die Meldung, dass Java 6 benötigt wird. Der genau Wortlaut der Meldung ist: "Um java öffnen zu können benötigen Sie eine Java SE 6-Runtime. Möchten Sie eine Version jetzt installieren?"
    Wenn ich auf "Installieren" klicke, dann wird Java 6 von Apple über den Mac App Store installiert. Das möchte ich aber nicht, sondern ausschließlich Java 7 verwenden.

  • Das scheint auf ein Problem mit Ihrer Java-Installation hinzudeuten - das Java Browser-Plugin ist installiert und funktioniert auch, aber die Java-Anwendung selbst wird nicht gefunden. (Die Verknüpfung zur java-executable scheint nicht korrekt installiert zu sein.)
    Eventuell hilft eine Neuinstallation von Java 7.

  • Code
    1. which java


    zeigt

    Code
    1. /usr/bin/java


    an.

    Code
    1. ls- l /usr/bin/java


    zeigt

    Code
    1. lrwxr-xr-x 1 root wheel 74 13 Dez 17:06 /usr/bin/java -> /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java


    an.
    Bei Eingabe von

    Code
    1. java -version


    kommt

    Code
    1. No Java runtime present, requesting install.


    und ein Hinweis "Um das java-Befehlszeilenprogramm nutzen zu können, müssen Sie ein Java-Einwicklerpaket installieren.
    Ich kann auf OK klicken oder auf "Weitere Infos.." wobei ich beim Klick auf "Weitere Infos" auf http://www.oracle.com/technetw…vase/downloads/index.html weitergeleitet werde.

  • Das ist die Lösung. Nach der Installation des JDK ließ sich PDF-Over problemlos starten.
    Verstehe nicht warum das JRE nicht ausreicht.


    Vielen Dank für Ihre Hilfe!