Wünsche an MOCCA

  • Liebe MOCCA-Entwickler!


    Bitte berücksichtigt folgende Wünsche:


    1) Wenn das zu signierende Dokument "darstellbar" ist zeigt es bitte auch gleichzeitig
    mit dem "Signaturdialog" an. (siehe seinerzeitiges trustDesk-Applet)


    2) Implementiert bitte eine Funktion, mit der signierte Dokumente verifiziert werden können, ohne dass diese zu einem Server hochgeladen werden müssen. PDF-OVER / PDF-AS sowie die MOA-SP stell(t)en diese Funktion ja bereit. Linuxer sind darauf angewiesen, da dies derzeit von keinem Produkt unterstützt wird.


    3) Überprüft die Meldedialoge beim Ummelden von alter auf neue Generation der e-card (bei A-trust). Dabei werden keine Beschreibungen der zu befüllenden Felder angezeigt. (Nur drei leere Formularzellen.) Mit etwas Suche im Web findet man zwar heraus in welches Feld was gehört (welche PINS), das ist einem Otto-Normalo aber wohl nicht zuzumuten.


    Vielen Dank im voraus!


    Ein gutes neues Jahr!

  • MOCCA ist darauf ausgerichtet, den Hauptanwendungsfall "Anmeldung in Anwendung" betriebssystem-unabhängig zu unterstützten. Dabei vor allem auch in der Online-BKU in Anwendungen ohne lokale Installation auszukommen.


    Zu Frage 1 (baum): Die Anzeige ist deshalb als Link ausgeführt, um auch in kleinen Browserbrereichenlauffähig zu sein (zB Navigationsleiste, vgl. FinanzOnline). Ein Anzeigebereich im Benutzerdialog ist deshalb nicht vorgesehen.


    Zu Frage 2 (baum): Die Signaturprüfung ist in MOCCA nicht geplant. Es würde Größe und Komplexität deutlich erhöhen.


    Zu Frage 3 (baum): Das ist ein Fehler seit dem vorletzten Java-Update (ab 1.6 update 22), von dem auch andere Applets betroffen sind. Wenn ein Applet gecached ist (Neuladen des selben Applets im Browser), zeigt Java keinen Text mehr an. Hier git es noch keine Lösung.


    Zu PKCS11: MOCCA verwendet kein PKCS#11. Das zweite Schlüsselpaar (RSA) ist auf Karten angeboten, die Bürgerkartenfunktion (auf die MOCCA beschränkt ist) verwendet nur die qualifizierte Signatur. Im Rahmen MOCCA ist eine PKCS#11 Entwicklung nicht geplant (PKCS#11 Treiber sind zB via A-Trust für Windows verfügbar. Zu Planungen/Stand der Aktualisierung Linux kann nur A-Trust selbst Auskunft geben, vgl. [url=https://www.buergerkarte.at/mvnforum/mvnforum/viewthread_thread,36#910]thread 36[/url] )