PDF-Over Installation schlägt fehl

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • PDF-Over Installation schlägt fehl

      Beim Versuch PDF-Over unter Linux zu installieren bekomme ich reproduzierbar diese hässliche Fehlermeldung:

      Quellcode

      1. java.io.IOException: Corrupted pack file: magic/ver = CAFED00D/171.0 should be CAFED00D/150.7 OR CAFED00D/160.1
      2. at com.sun.java.util.jar.pack.NativeUnpack.start(Native Method)
      3. at com.sun.java.util.jar.pack.NativeUnpack.run(Unknown Source)
      4. at com.sun.java.util.jar.pack.NativeUnpack.run(Unknown Source)
      5. at com.sun.java.util.jar.pack.UnpackerImpl.unpack(Unknown Source)
      6. at com.izforge.izpack.installer.Unpacker.run(Unknown Source)
      7. at java.lang.Thread.run(Unknown Source)
      Quelle des JARs: webstart.buergerkarte.at/PDF-Over/

      Ich werde jetzt erstmal die alte Version aus dem Backup wiederherstellen … ||
    • Sorry, es ist vermutlich kein Problem des Downloads. Ich hab's jetzt 3x versucht und erhalte immer wieder dieselbe (kaputte) Datei. MD5sum b49dd5df56e8ae579df5825176f86c02, falls Sie das prüfen möchten. Immer wieder die Fehlermeldung "Corrupted pack file: magic/ver = CAFED00D/171.0 should be CAFED00D/150.7 OR CAFED00D/160.1". Leider kann ich nicht einmal die aus dem Cache der Nachbarmaschine gezogene Version verwenden... die installiert zwar, meldet sich aber bei Aufruf mit "unerwarteter Fehler". Als nacktes Archiv öffnet das .jar problemlos, die Datei an sich scheint also durchaus nicht beschädigt zu sein. Bitte um Reparatur, dankeschön.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Fafhrd () aus folgendem Grund: 2 typos korrigiert

    • So, nähere Betrachtung ergibt folgendes:

      - Die Dateien /packs/pack200-31 bis -34 sind offenbar im Format 171.0 gepackt worden.
      - Java 7u181 (the latest & greatest) akzeptiert jedoch anscheinend maximal 160.1.
      - Die Specs von Oracle sehen 170.1 erst in Java 8 vor, wann 171.0 dazugekommen ist, erschließt sich nicht so recht.
      - Das Package Manifest stammt von 1.6.0_26, die Signatur jedoch bereits von 9.0.4.
      - Für meine aktuelle LMDE2 (Debian Jessie) hier ist allerdings openjdk-7_181 das aktuellste in den Repos. Anderen Nutzern (s.o.) geht es vmtl. ähnlich...

      Nach Installation von Java 8 über ein 3rd party PPA funktioniert das Ganze jetzt. Auf einer Testmaschine.

      Wäre es vielleicht möglich, das .jar durchgängig mit pack200 <= 160.1 bereitzustellen? Dann könnten auch Installationen mit "konservativer" stable codebase es nutzen, die u.A. repo-fremde Installationen vermeiden möchten/müssen. Oder aber an prominenter Stelle des Hinweis anzubringen, dass Java >= 8.x.x erforderlich ist? Dann hätte ich mir 9 Stunden Sucherei & Tüftlerei erspart...

      Vielen Dank!